Eclipse

Ubuntu Türkiye Wiki sitesinden
Atla: kullan, ara
Stock search-and-replace.png
Bu maddenin elden geçmesi gerekmektedir.
Madde, biçimlendirme özellikleri bakımından diğer maddelerle uyumsuz olabilir ya da dilbilgisi ve anlatım bozuklukları içeriyor olabilir.
Düzenleme yapıldıktan sonra bu açıklama kutucuğu silinmelidir.


Eclipse
Eclipse - Ubuntu üzerinde Eclipse
Ubuntu üzerinde Eclipse
Geliştiren(ler): Eclipse Vakfı
İşletim sistemi: Linux, Windows, Mac OS X
Türü: Tümleşik geliştirme ortamı
Lisansı: Eclipse Kamu Lisansı (EPL)
Resmi sitesi: www.eclipse.org
Eclipse-logo.png

Eclipse, açık kaynak kodlu bir tümleşik geliştirme ortamıdır (IDE). Ana odak noktası Java ve Java ile ilişkili teknolojiler olsa da esnek yapısı sayesinde C ve Python gibi farklı diller için de kullanılmaktadır.

2001 yılında IBM tarafından başlatılan proje Java'nın ana grafik sistemi olan Swing yerine bulunduğu platformda bulunan özellikleri doğrudan kullanan SWT'yi kullanarak Java dünyasında tartışmalara yol açmıştır. Hızlı arayüzü, şık görünümü ve çok kuvvetli özellikleriyle kısa zamanda Java geliştiricileri arasında en popüler geliştirme ortamı olmuştur. 2005 yılında Eclipse projesinin yönetimi Eclipse Vakfına bırakılmıştır.

Ayrıca sunulan eklentiler ile işlevleri geliştirilerek bir çok alanda kullanılabilmektedir.

Kurulum

Eclipse yazılım geliştirme ortamını kurmak için Ubuntu Yazılım Merkezini kullanabilir veya Uçbirimde alttaki komutu kullanabilirsiniz.

sudo apt-get install eclipse

Kullanımı

Bu yazıda kullanışlı bir IDE olan Eclipse'i inceleyeceğiz. kolaylıklar sağlamak olan bir araç. Bu yazıda derleyici olarak GCC Eclipse'in genelde Java için kullanıldığı bilinse de aslında C/C++ için kullanılacak ve Eclipse IDE tanıtılacaktır. de yeterli özelliklere sahip bir IDE sunmaktadır. Bu genel bilgilerden sonra Eclipse'in C/C++ geliştirmek için Öncelikle derleyici ve IDE kavramlarından biraz bahsedip sunduğu IDE'yi nereden indirebileceğimizden bahsedelim. farkına değinelim. http://www.eclipse.org/downloads/ IDE: Tümleşik geliştirme ortamı, bilgisayar programcılarının hızlı ve rahat bir şekilde yazılım geliştirebilmesini amaçlayan, Adresinden Linux için olan paketlerden, sisteminizin mimarisine geliştirme sürecini organize edebilen birçok araç ile birlikte geliştirme göre olan sürümünü indirin (i386/amd64). Daha sonra sıkıştırılmış sürecinin verimli kullanılmasına katkıda bulunan araçların tamamını olarak inen (.tar.gz) dosyayı istediğiniz dizine çıkartıp, sıkıştırılmış içerisinde barındıran bir yazılım türüdür. dosyadan çıkarttığınız bu dizin içine girin. Dizinde birkaç tane dosya göreceksiniz, fakat kurulum için ayrıca bir zaman harcamayacağız. Tümleşik geliştirme ortamlarında olması gerekli en temel Girdiğiniz dizindeki ikilik dosyayı (dosya içerisindeki adı “eclipse”) çift özellikler: tıklayarak doğrudan IDE'yi çalıştırabilirsiniz. Fakat bu dosyayı Programlama diline göre sözdizimi renklendirmesi yapabilen kod çalıştırabilmek için sisteminizde Java'nın yüklü olması gerekir. Yoksa yazım editörü. aşağıdaki gibi bir hata alırsınız. Hatada zaten sisteminizde kurulu Kod dosyalarının hiyerarşik olarak görülebilmesi amacıyla hazırlanmış olması gereken bileşenler söyleniyor. gerçek zamanlı bir dizelge. Tümleşik bir derleyici,yorumlayıcı ve hata ayıklayıcı. Yazılımın derlenmesi, bağlanması, çalışmaya tümüyle hazır hale “A Java Runtime Environment (JRE) or Java Development Kit gelmesi ve daha birçok ek işi otomatik olarak yapabilmek amacıyla (JDK) must be available in order to run Eclipse...” şeklinde devam küçük inşa araçları. eden bir hata. Derleyici: Programcılıkta, bir program dilinde yazılmış olan Java yüklemek yazının konusu olmadığı için doğrudan kaynak kodunu başka bir dile (genellikle makine koduna) çeviren geçiyorum, isteyen forumumuzda önceden açılmış olan başlıklardan yazılım. yararlanarak sistemine Java'yı kurabilir. (kaynak: tr.wikipedia.org) Yani IDE derleyiciyi de kapsayan, aslında amacı programcıya Java engelini aştıysanız az önce bahsettiğimiz “eclipse” dosyasına çift tıkladığınızda sizi Eclipse'in logosu karşılayacaktır ve daha sonra şöyle bir soru ile karşılaşacaksınız: Burada size sorulan proje dosyalarının oluşturulacağı dizindir. Ben bu şekilde varsayılan olarak sunulanı kabul edip bir de “Use this as the default and do not ask again” şeceneğini işaretleyerek onay veriyorum. Bu şekilde programı her açtığınızda size kullanılacak olan dizin sorulmayacak ve kullanıcı ev dizininiz altında “workspace” adında bir dizin oluşturularak bütün projeleriniz bu dizinde alt dizinler halinde saklanacaktır. Zaten bu şekilde ayarladıktan sonra da yeni bir proje oluştururken, önceden ayarladığınız dizinde çalışmak istemiyorsanız değiştirme şansınız olacak. Çalışma dizinini belirledikten sonra yukarıda örneği verilen gibi pencerede bir kaç seçeneğimiz olacak. Biz doğrudan proje geliştirmeye başlamak için, en sağda olan "Workbench (go to workbench)" seçeneğine gidiyoruz ve asıl kullanacağımız ve işimize yarayacak olan penceremiz açılıyor. "Workbench" seçeneği ile açtığımız pencerede "shift + alt + N" kombinasyonlarını kullanıp yeni proje oluşturma menüsünü açıyoruz. Tabii ki bu menüye ulaşmak için tek seçeneğimiz bu tuş kombinasyonu değil. Yeni proje oluşturmak için program menülerindeki "File -> New" yolunu takip ederek aynı menüye ulaşabilirsiniz. Yeni projeler oluşturmak için seçeneklerimiz yine bu kadar değil, diğer seçenekten biraz sonra bahsedeceğiz. Program geliştiricileri genelde işlerini klavye ile halletmeyi sevdikleri için (ya da öyle daha kolaylarına gittiği için...) bu tuş kombinasyonlarını da vermek istiyorum. Çünkü Eclipse gerçekten çok az bir fare kullanımı ile hemen hemen istediğiniz her işi yapmanıza olanak sağlıyor. Toparlayalım, en son "shift + alt + N" kombinasyonu ile aşağıdaki resimde görülen menüyü açmıştık. Ben örneklerimi C üzerinden anlatacağım. O nedenle burada açtığımız menüden "C project" seçiyorum. Diğer seçeneceklerden projeyi oluşturduktan sonra bahsedeceğim. 5 Se m e t e y C OŞKUN Proje oluştururken "C Project" seçtiğimiz menüde başka Karşınıza çıkan daha büyük bir menü olacak fakat bu kadarlık ayar, ilk projeye başlamak için size yeterli olacaktır. "Project name" seçenekler de vardı ve sonra bahsedeceğimizi söylemiştim, o kısmına geliştireceğiniz projenin adını yazın. Aşağıdaki tik, proje seçenekler ile burada da karşılaşacağız. dizinimizin, program açılırken varsayılan olarak belirlediğimiz dizinin Şimdi boş projemize sağ tıklayarak (SUDO yazan yeri sağ altında yaratılacağını söylüyor. Bu şekilde "Finish" dersek eğer ("Finish" tuşu menünün en aşağısında, ben oraları resme dahil etmedim), pasif tıklıyoruz) yeni menü açıyoruz. halde gösterilen "Location" bölümündeki dizin oluşturulacak ve projede kullanacağımız diğer birimler (kaynak kodlar, başlık dosyaları ) bu SUDO dizini altında oluşturulacak. Yazının başında eğer istersek çalışacağımız dizini değiştirebildiğimizi söylemiştim. İşte eğer istersek değiştirebildiğimiz bölüm, bu bölüm. Burada istediğiniz dizini el ile girebilirsiniz (ya da "Browse" seçeneğini kullanabilirsiniz). Ben varsayılan dizinimi kullanarak devam ediyorum... Ayrıca menüdeki, benim resme dahil etmediğim bölümlerden "Toolchains" bölümünde de Linux GCC olması gereklidir (genel olarak hepimiz GCC kullanıyoruzdur diye düşünüyorum). Projemizi oluşturduk. Şu aşamada "Project Explorer" bölümünde projenizi görebiliyor olmanız gerekiyor. Benim projem "SUDO" olarak gözüküyor ve eğer isterseniz bu SUDO'ya sağ tıklayarak "go into" seçeneği ile sadece "SUDO" dizini içerisindeki birimleri gösterebilirsiniz. Tabii şu anda projemizin içi boş. İçinde herhangi bir dosya yok. Ev dizininizdeki "workspace -> SUDO" içeriğini kontrol ederek boş olduğunu görebilirsiniz (ya da hangi dizinde proje oluşturduysanız). Dizine baktınız içi boş, "ama 'Project Explorer' içerisinde bir takım şeyler var" diyorsanız, onlar sistemde bulunan dosyalardır. Projelere dahil edebilirsiz (#include) ama proje dosyasınızda gözükmeyecektir. 6 Se m e t e y C OŞKUN Gördüğünüz gibi açılan menünün "new" sekmesi, ilk başta "shift + alt N" kombinasyonu ile açtığımız menünün hemen hemen aynısı. Bu menüden projenize; dosya (file), dizin (folder), kaynak kod dosyası (source file), başlık dosyası (header file), yeni sınıf dosyası (class), ve proje gibi istediğiniz birimi ekleyebiliyorsunuz. Projemiz boştu, şimdi yeni bir kaynak kod dosyası oluşturup ufak bir program yazabiliriz. Bunu yapabilmek için projeye yukardaki menüden "Source File" seçeneğini (fare imlecinin üzerinde bulunduğu seçenecek) eklemeniz gerekiyor. Ben kaynak dosyamın adını "program.c" yaparak projeme ekliyorum. Artık projemde bir kaynak dosyam da var. Eklediğiniz kaynak dosyasını aşağıdaki şekilde "Project Explorer" içerisinde, SUDO altında görebilmeniz gerekir (resimdeki işaretlerin nedenini iki paragraf sonra belirtiyorum). Kaynak kod dosyasının bulunacağı dizini "Source Folder" kısmına giriyoruz. Ben doğrudan proje dosyasını kullanacağım siz isterseniz az önceki menüden, projeye bir "Source Folder" ekleyerek kaynak kodunuzu bu dizinin içerisinde oluşturabilirsiniz. Resmin ikinci satırındaki "File name is empty" hatası kaynak dosyamıza isim verdiğimizde ortadan kalkacak. Yalnız dikkat etmeniz gereken; C projesi oluşturduğumuz için, kaynak dosyasının uzantısı ".c" olmalıdır. Aksi takdirde; "File name is discouraged. File extension does not correspond to known source file types." şeklinde bir hata alırsınız. Tek yapmanız gereken dosya adını ".c" uzantısı ile bitirmeniz. Aynı yolu takip ederek, başlık dosyası ya da istediğiniz her birimi projenize dahil edebilirsiniz. 7 Se m e t e y C OŞKUN Aynı yolu takip ederek, başlık dosyası ya da istediğiniz her #include <stdio.h> birimi projenize dahil edebilirsiniz. int main() Yeni proje oluşturma, kaynak dosyası ekleme, başlık dosyası { fprintf(stdout, "Ubuntu Türkiye E-Dergisi SUDO"); ekleme gibi işlemleri yapmak için ayrıca bir alternatifimiz daha var. Bütün işlemleri, anlatılanların yanında, yukarıdaki resimde kırmızı } çizgi ile altı çizilen bölüm ile de yapabilirsiniz. Fare imlecini üzerinde tuttuğunuzda hangi düğmenin, projeye ne eklediği bildiri balonu Bu kodları doğrudan "program.c" içerisine yazıyoruz (yeni bir olarak size söylenecektir. Ayrıca düğmelerin yanındaki "aşağı doğru kaynak kod dosyası oluşturunca otomatik olarak yazar belirtilip tarih olan okları" da daha fazla seçenek için kullanabilirsiniz. atılıyor, isterseniz silebilirsiniz, isterseniz kullanabilirsiniz, tamamen size Şimdi program yazıp derlemeye de örnek gösterebiliriz fakat öncelikle kalmış). Derlemek için "ctrl + b" tuşlarını kullanabilirsiniz. Ya da genel olarak Eclipse'in olumsuz olarak görülen bir özelliğini aşalım. program menülerinden "Project -> build all" yolunu izleyerek projeyi Ekranda, gördüğünüz gibi kod yazacağımız alan çok dar. Özellikle derleyebilirsiniz. Programı çalıştırmadan önce hata olup olmadığını ekranımızın boyutu büyük değilse bu gerçekten sıkıntı verebilecek bir kontrol etmemiz lazım. Bu nedenle kendimize yer açarken durum. Fakat bu durumun çok basit bir şekilde geçeceğiz. Resimde küçülttüğümüz menülerden en alttakini tekrardan açıyoruz. yeşil ok ile göstermiş olduğum yerlere tıklayarak bütün bileşenleri (Kodları derlemeden önce kayıt ettiğinizden emin olun. Kayıt ekrandan alıp, bütün ekranı sadece kod yazacağımız alana etme işlemi için "ctrl + s" kombinasyonunu kullanabilirsiniz. Ya da yine verebiliriz. Bu şekilde diğer bileşenleri kapatmadan, sadece ekranda gizleyip istediğimiz zaman da ulaşabiliriz. Ekranda sakladığımız bu menülerden yararlanabilirsiniz. Eğer dosyanızda kaydedilmemiş bir bileşenlere tekrardan ulaşmak için fare üzerine geldiğinizde "Restore" değişiklik varsa, dosya isminizin yazdığı sekmede, dosya isminin yazan düğmeyi tıklamanız yeterli. Bu düğmenin şekli de resimde mavi başında bir yıldız göreceksiniz) ok ile belirtildiği gibi bir hal alacaktır (menüleri sakladıktan sonra). Yeterli alana da sahip olduktan sonra kod yazmaya başlayabiliriz. Yazdığım kod tahmin edeceğiniz gibi çok basit bir kod. Ama "hello world" değil. 8 Se m e t e y C OŞKUN Aslında resimde gördüğünüz gibi fare imleci ile de bir hata/uyarı olduğunu/olmadığını bildiri balonu sayesinde anlayabiliyoruz. Hatta fareye dahi ihtiyaç duymadan resimde oklar ile belirttiğim yerlerden de hata ve uyarıları anlayabiliyoruz. Soldaki okun gösterdiği sarı bir ünlem işareti ise uyarı, kırmızı zemin üzerinde bir çarpı olursa hata anlamına geliyor. Sağdaki okun gösterdiği çizginin ise renginin sarı olmasından uyarı, kırmızı olmasından hata olduğunu anlayabiliyoruz. Fakat bizim örneğimiz uçbirimde çalışacağı için fare imlecinin üzerinde bulunduğu menünün "Restore" tuşuna basmamız gerekiyor. Çünkü Eclipse, uçbirim çıktılarını bu menüdeki "Console" sekmesi altında veriyor. Aynı menüdeki "Problems" sekmesinden ise hataları ve uyarıları görebilir, istediğiniz hataya ya da uyarıya çift tıklayarak odaklanma sağlayabilirsiniz (hatta farenin resimde belirttiği bölümden Console, Problems gibi sekmeleri ayrı menüler halinde de açabilirsiniz). Bizim örneğimizde uyarı, okların gösterdiği bölümlerden hemen görülüyor fakat 2000 satırlık kod içerisinde bu şekilde hata yakalamaya çalışmak çok mantıklı olmayacaktır. Aldığımız uyarı ise "int" türünden geri dönüşe sahip bir fonksiyonu (main() fonksiyonu) geri dönüş olmadan kullandığımızı belirtiyor. Bu aslında IDE'nin değil, derleyicinin yani GCC'nin bir özelliğidir. Aynı kodları terminalden GCC ve nano kullanarak -Wall parametresi ile derlediğinizde yine alırsınız. Yani burada derleyici ayarlarında -Wall parametresinin bulunduğunu anlayabiliriz. Bu uyarıyı aşmak için kod sonuna "return 0;" eklemek yeterli olacaktır (burada hatayı aşmak için main fonksiyonunu void yaparsanız bu sefer başka uyarı alırsınız. Çünkü programların -fonskiyonların değil programların- sonlanırken geri döndüğü değer, işletim sistemi tarafından anlamlı olabilmektedir). Daha sonra tekrar derliyoruz. "Problems" bölümünde 0 hata ve 0 uyarı olduğunu göreceksiniz. Programı derledikten sonra çalıştırmadan önce "Console" sekmesinden programınızın hangi parametreler ile derlendiğini görebilirsiniz. Programı çalıştırmak için "ctrl + F11" kombinasyonunu kullanabilirsiniz. Ya da program menülerinden "Project -> run" sekmesini kullanabilirsiniz. Projeyi derleyip, çalıştırma işlemleri için de alternatiflerimiz bunlar ile sınırlı değil. Resimdeki yeşil olarak altı çizilen menülerden de bu işlemleri yapabilirsiniz. Aşağıdaki menüyü (Problems ve Console sekmelerini içeren menü) hata kontrolü ya da çıktılara bakma işleminizden sonra tekrar kapatıp, kod yazdığınız geniş alana tekrar sahip olabilirsiniz. "Project Explorer" menüsünden ise projenizden istediğiniz birimi (dosyalar ve dizinleri) çift tıklayarak inceleyebilirsiniz. 9 Se m e t e y C OŞKUN Yazının konusu kod yazmak olmadığı için incelemek üzere kod yazmayıp zaten hazır kodlardan faydalanarak başka özelliklerden de bahsetmek istiyorum. Resimde sadece kod yazdığımız alan ve program ilk açıldığında sağ tarafta bulunan ve bizim ekrandan tasarruf etmek için küçülttüğümüz menü var. Siz de bu resimdeki menüyü kullanabilmek için "Restore" tuşuna basmalısınız ve açılan menüdeki sekmelerden "Outline" sekmesinde olmalısınız. Project Explorer, Problems, Console gibi menülere bakmıştık. Şimdi de resimde gözüken Outline menüsüne bakacağız. Resimde gözüken yeşil noktalar fonksiyonları, mavi noktalar ise tanımladığımız değişkenlerimizi gösteriyor. Daha yakından bakalım: Yeşil nokta olmasından fonksiyon olduğunu anlıyoruz. Bu resimdeki bilgilerden çıkarabildiklerimiz; "oku" adında, ilk parametresi int türü, ikinci parametresi bir dosya gösterici, üçüncü parametresi ise bir karakter dizisi olmak üzere üç parametreye sahip ve char türünden adres ile geri dönen bir fonksiyon olduğudur. Mavi bir nokta. Buradan da ResimEntry adında GtkWidget türünden bir gösterici tanımlandığını anlıyoruz. 10 Se m e t e y C OŞKUN Bu işaret başlık dosyaları için kullanılıyor. Yani malloc.h başlığı programa dahil edilmiştir. Bu işaret ise önişlemci komutlarını belli ediyor ki zaten C'de de aynı işaret kullanılıyor (#define gibi). Bu işaret ise fonksiyon prototiplerinde kullanılıyor. Buradan Acilis fonksiyonunun static olduğunu, geri dönüş değeri ve parametereye sahip olmadığını ve kod içerisinde prototipinin tanımlandığını anlıyoruz. Bütün bu bilgileri Outline menüsünden kontrol edebiliyorsunuz. Bu bilgileri kontrol etmenin yanında istediğiniz fonksiyona bu menüden tıklayarak da ulaşabiliyorsunuz. Üzerinde bulunduğunuz fonksiyona F3 tuşu ile odaklanabilirsiniz (ya da sağ tık -> open declaration). Bu menü aktif halde iken doğrudan Nautilus'daki gibi arama yapabiliyorsunuz (isim yazarak). Örneğin bir değişkenin üzerine geldiğinizde, o değişken bütün kodlarda üzeri taralı olarak belirginleşiyor ve takip ettiğiniz değişkeni kod içerisinde rahat seçebiliyorsunuz (bir kaç önceki resimde gösterdiğimiz, hataların ve uyarıların kırmızı - sarı çizgilerle belirtildiği bölümde, üstü taranan değişkenlerin de yeri tayin edilebiliyor. Değişkenlerin yerleri ise gri çizgi ile belirtilmektedir.). En güzel ve kolaylık sağlayan özelliklerinden; bir değişken ya da fonksiyon üzerine "ctrl" tuşuna basarak fare imlecini getirdiğinizde, üzerinde bulunduğunuz birim (fonksiyon, değişken, tür) bir bağlantı halini alıyor. Bu bağlantıya tıklandığı zaman o fonskiyon ya da değişkenin tanımlandığı dosyaya sekme olarak ulaşmış oluyorsunuz. Örnek olarak "FILE" türü üzerinde bu şekilde tıklandığı zaman "stdio.h" başlığının yeni bir sekme olarak açıldığını göreceksiniz (FILE stdio.h içerisinde oluşturulmuştur (typedef)). Yine söylemeden geçilmeyecek başka bir özellik; bir fonksiyon üzerine farenizi götürdüğünüzde fonksiyonu ufak bir açılır pencerede görebiliyorsunuz ve fonksiyonu görmek için kod içerisinde aramanıza gerek kalmıyor. Ayrıca bir fonksiyon üzerindeyken "ctrl + alt + h" tuşları ile fonksiyonun kullanıldığı yerleri hiyerarşik biçimde görebiliyorsunuz (tahmin edersiniz ki sağ tuş ile de yapabilirsiniz). Kod yazarken kullandığımız bölümde birden fazla sekme açıp fazla dosya ile çalışabiliyoruz. Buradaki aktif olan sekmeyi (örnek resimde "program.c" sekmesi) alternatif olarak "ctrl + w" kombinasyonu ile de hızlıca kapatabiliyorsunuz. 11 Se m e t e y C OŞKUN Resimdeki görüntüyü sadece faremi "yer_ayir" fonksiyonu üzerinde sabitleyerek elde ediyorum. yer_ayir fonksiyonu gördüğünüz gibi açılıyor ve fonksiyonu bütünü ile inceleyebiliyorsunuz. Açılan yeni pencereyi aktif hale getirmek için fare imleci ile tıklamanız ya da F2 tuşuna basmanız yeterli olacaktır (programın fontlarından dolayı pencere arka plan rengi ve yazıların (kodların) rengi siyahtı, gözükebilmesi için fare ile üzerini taradım). Bunlar normal bir projeyi geliştirmek için gerekli ve işimizi kolaylaştıracak temel bilgiler. Biraz daha detaya inelim. Örneğin bir GTK programı geliştiriyorsanız programı derlemek için ek parametreye ihtiyanıcınız olur. `pkg-config --libs --cflags gtk+-2.0` gibi. Bu parametreyi bir projeye de ekleyebiliyoruz, doğrudan IDE ayarlarına da ekleyebiliyoruz. Ben IDE ayarlarına eklemeyi göstereceğim. Böylece projelerde bu değişkeni tekrar tanıtmak yerine sadece gerekli projelere ekleyebiliriz. Zaten projeye ekleme ile IDE'ye ekleme arasında da çok fazla fark yok. Sadece ekleyeceğimiz yer proje değil, IDE ayarlarından olacak. Resimdeki sekmeden derleyici ayarlarını görebilir ve değiştirebilirsiniz. Örneğin ilk programımızda "-Wall" parametresi nedeni ile programımız derleme zamanında uyarı vermişti. Bu sekmedeki "Warnings" bölümünden derleyicinin bu ayarlarını kontrol edebilir ve değiştirebilirsiniz. Yine "Settings" sekmesinde bulunan "Optimization" bölümünden "Project Explorer" derleyici optimizasyon seçeneklerini ayarlayabilirsiniz. Varsayılan menüsünden projenizi sağ olarak bu değer -O0'dır. tıklayarak "Properties" seçeneğine girin (bizim "Build Variables" sekmesine geçerek derleme parametrelerine örneğimizde SUDO'yu sağ katacağınız yeni değişkenleri belirleyebilirsiniz. Derlemeye katacağımız tıklıyoruz). parametreler ne olabilir? Program menülerinden (File, Edit, Source...) "Window -> Preferences" yolunu izliyoruz ve açılan pencereden aşağıdaki sekmeye geliyoruz (C/C++ -> Build -> Build Variables) ve "Add" düğmesine basıyoruz (Add düğmesi gözükmezse pencereyi büyütmeyi deneyin). 12 Se m e t e y C OŞKUN "Variable name" kısmında "gtkp" zorunlu değildir, ben ne olduğu anlaşılsın diye "gtkp" olarak belirliyorum (gtk parametresi gibi). "Value" kısmına ise parametrenizi yazın; "Ok" deyin ve ana menüde de "Ok" diyerek menüleri kapatın. Burada IDE'ye "gtkp" parametresinin değerinin "Value" kısmına yazdığımız değer olduğunu bildirmiş olduk, artık IDE'miz bu değeri biliyor. Şimdi tekrardan projemizin özelliklerine geliyoruz (SUDO -> sağ tık -> Properties) ve aşağıdaki kısmı açıyoruz; Gördüğünüz gibi derleyici ayarlarında "Miscellaneous" sekmesindeki "Other Flags" kısmına "gtkp" değişkenimi ekliyorum. Burada "-c fmessage-length=0" kısmı zaten vardı. Biz sadece bir boşluk bırakıp "${gtkp}" kısmını ekliyoruz. Parametrenizi "gtkp" olarak değil de "${gtkp}" biçiminde eklemeniz gerektiğini unutmayın. Yoksa gerekli başlık dosyalarınız tanınmaz ve yine hata alırsınız. Unutmayın "gtkp" değil ${gtkp}... Burada ekledikten sonra "GCC C Linker" (bağlacıyı) ayarlarından yine aynı bölüme (Miscelanneous bölümü) geliyorum. Burada "Linker Flags" isminde bir bölüm var. Değişkenimizi (gtkp) aynı şekilde buraya da ekliyoruz. Buraya da "${gtkp}" şeklinde eklemeniz gerektiğini unutmayın. Linker Flags bölümü sizde de boş olacaktır, parametreyi ekleyip onaylayınız. Bundan sonra GTK programlarını da Eclipse ile derleyebilirsiniz. Ek parametre gerektiren başlık dosyaları tabii ki sadece GTK için değil, öyneğin MySQL kütüphaneleri için de aynı şekilde ek parametre ile derlemek zorundasınız. Aynı yöntem ile istediğiniz parametreleri ekleyebilirsiniz. Biz programın ana menülerinden "Windows -> Preferences" bölümünden "Add Variables" seçeneğini kullandık. Bu şekilde IDE genelinde bu parametreleri tanıtmış oluyoruz. Eğer SUDO -> sağ tık - > Properties -> Add Variables deseydik bir sonraki projemizde aynı işlemi tekrar yapmak zorunda kalacaktık. Ama bu şekilde IDE'ye genel olarak tanıtınca, projelerde sadece derleyici ve bağlayıcı ayarlarındaki 13 Se m e t e y C OŞKUN "Miscellaneous" bölümlerinden eklemek yeterli olacaktır. Bir başka özellik; Eclipse programın kod olmayan kısımlarında yazım denetmi yapmaktadır (karakter dizileri ve yorum satırları). Bu nedenle; fprintf(stdout,"Programda hata var\n"); /*Program yazım denetimi yazıyor*/ Şeklinde Türkçe kullandığınız açıklamaların ve dizilerin Bu şekilde yazım denetimini iptal ederek Türkçe kelimelerin altının çizilmesini engelleyebilirsiniz. hepsinin altı çizili olarak Son olarak kişisel ayarlardan birisinden bahsedelim. Bu sefer kodu yazdığımız bölümde sağ tık yapıyoruz gözükecektir. Bu durumun ve açılan menüler arasından "Preferences" seçeneğini bulup giriyoruz. önüne geçmek için; Resimdeki yolu izleyerek istediğimiz renkleri zevkimize göre ayarlıyoruz. İşlem yapılan satırın rengi, arka Program menülerinden; plan rengi, birimler üzerinde ctrl tuşu ile oluşturduğumuz bağlatıların renkleri, fare imleci ile bir alan "Window -> Preferences" tarandığında; taranan alanın arka plan rengi, taranan alandaki yazıların rengi gibi bir çok yeri zevkinize göre sekmesinden ulaşacağınız değiştirebilirsiniz. aşağıdaki bölümde "Enable spell checking" kısmının tikini Sanırım değinemediğim ve bilmediğim daha bir çok özelliği var fakat bu kadarı bile proje geliştirmeye kaldırmanız gerekiyor. başlamak için yeterli. Herkese şimdiden kolay gelsin diyerek bırakalım...

Kaynakça

SUDO e-dergi - 26. Sayı

Kişisel araçlar
Ad alanları

Türevler
Eylemler
Gezinti
wiki
Araçlar